API Performance Degradation

Incident Report for Lago

Resolved

This issue has been resolved. The slowdown was caused by a very high volume of events and increased traffic on the current usage endpoint, coming from one customer on the US cluster. The team scaled the service within seconds of detecting the issue, and API performance has since returned to normal levels.
Posted Nov 03, 2025 - 20:48 UTC

Update

We are continuing to investigate this issue.
Posted Nov 03, 2025 - 20:44 UTC

Investigating

We’re currently experiencing slower-than-usual API response times due to a surge in incoming requests. Our engineering team is actively scaling the infrastructure to restore normal performance and investigating the root-cause.
Posted Nov 03, 2025 - 20:17 UTC
This incident affected: Cloud US API.