Resolved
Latency has returned to normal levels. All services are operating as expected. Thank you for your patience.
Investigating
We are experiencing elevated latency on our API endpoints. Some API requests may take longer than usual. Our team is investigating and working to resolve this. We will provide updates as we learn more.