Resolved
Everything is back to normal
Monitoring
A fix has been released, system is back to normal, we're monitoring.
Investigating
We are seeing degraded performances on Plans update.
Investigating
We are experiencing elevated latency on our API endpoints. Some API requests may take longer than usual. Our team is investigating and working to resolve this. We will provide updates as we learn more.