The system is stable and the immediate impact has been resolved.
We're now processing a significant backlog of billing events that built up during the incident. This may take a while to fully clear. During this window, customers may notice delays in billing processing. All events and invoices will be processed once the backlog is cleared.
We're monitoring progress closely and will update this page as the system fully catches up.
Monitoring
The system is stable and the immediate impact has been resolved.
We're now processing a significant backlog of billing events that built up during the incident. This may take a while to fully clear. During this window, customers may notice delays in billing processing. All events and invoices will be processed once the backlog is cleared.
We're monitoring progress closely and will update this page as the system fully catches up.
Identified
We've identified the root cause and are working on a fix. Customers may notice delays in billing processing in the meantime. We'll post another update as soon as the fix is rolled out.
Investigating
We are currently experiencing a service outage. Our systems are not responding as expected. Our engineering team has been alerted and is actively investigating the issue. We will provide updates as soon as we have more information.
Investigating
We are experiencing elevated latency on our API endpoints. Some API requests may take longer than usual. Our team is investigating and working to resolve this. We will provide updates as we learn more.