No components marked as affected
Resolved
The system has fully caught up on the backlog and is operating normally
Monitoring
The surge that overloaded the affected system has subsided. The backlog is now draining and no customer-facing impact has been observed. We will continue monitoring until the queue is fully cleared.
Investigating
We are experiencing elevated latency on our API endpoints. Some API requests may take longer than usual. Our team is investigating and working to resolve this. We will provide updates as we learn more.