Invoicing Slowness

Incident Report for Lago

Resolved

This incident has been resolved.
Posted Mar 28, 2025 - 19:11 UTC

Monitoring

We're having some invoicing slowness, you can meet some delay during the invoicing progress, especially around in advance.

We had a very uncommon load for in advance invoice processing, it's under control but it added some delay for whole invoicing.
Posted Mar 28, 2025 - 15:54 UTC
This incident affected: Cloud US API.