Degraded performances on US cluster

Incident Report for Lago

Resolved

This incident has been resolved.
Posted Jul 03, 2025 - 01:10 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 03, 2025 - 00:32 UTC

Identified

We’re currently experiencing abnormal load on our US cluster. The issue has been identified, and we’re actively working to stabilize the system.
Posted Jul 03, 2025 - 00:18 UTC
This incident affected: Cloud US API.