Delayed Billing Jobs

Incident Report for Lago

Resolved

This incident has been resolved.
Posted Dec 05, 2024 - 00:16 UTC

Monitoring

Jobs are being processed, we monitor it.
Posted Dec 04, 2024 - 20:13 UTC

Update

US Cluster is impacted.
EU Cluster is safe.
Posted Dec 04, 2024 - 17:06 UTC

Identified

We are experiencing performance degradation and have a large backlog of background jobs on our cloud product (US cluster). As a result, the billing process may be delayed.
We are working to resolve this problem and will let you know when the situation returns to normal.
Posted Dec 04, 2024 - 16:57 UTC
This incident affected: Cloud US API and Lago Cloud Application.